Take Notes Feature in Edio is temporarily unavailable

Incident Report for CCA Status Page

Update

We are continuing to investigate this issue.
Posted Nov 25, 2024 - 10:11 EST

Update

We are continuing to investigate this issue.
Posted Nov 13, 2024 - 08:49 EST

Investigating

Take Notes Feature in Edio is temporarily unavailable
Posted Sep 04, 2024 - 08:32 EDT
This incident affects: MyEdio.