Edio performance - we are working on it!

Incident Report for CCA Status Page

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 16:40 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 09, 2026 - 14:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2026 - 13:30 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 12:25 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 12:06 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 11:26 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 11:01 EDT

Investigating

Welcome back everybody! We are working on improving the performance of Edio with a record number of students starting the year. We'll continue to post updates keeping you informed of our progress. Thank you for your patience.
Posted Sep 09, 2026 - 10:27 EDT
This incident affected: MyEdio.