Powerschool Maintenance App Pool Recycle and Environment Restart
Incident Report for CCA Status Page
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 16:17 EDT
Update
During Maintenance we've discovered some configuration issues that may be causing performance/reliability issues with the platform. Powerschool is running, and we're continuing to monitor.
Posted Jul 25, 2024 - 14:54 EDT
Investigating
We are restarting the powerschool environment for route maintenance and troubleshooting. Be back online around 12:20 PM.
Posted Jul 25, 2024 - 11:49 EDT
This incident affected: Powerschool.