Some staff may experience trouble accessing Powerschool without a VPN

Incident Report for CCA Status Page

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 09:06 EDT

Identified

Staff that are experiencing trouble access Powerschool may need to start the Global Protect VPN in order to login.
Posted Apr 24, 2025 - 07:25 EDT
This incident affected: Powerschool.