edio webmail

Incident Report for CCA Status Page

Resolved

Microsoft has resolved the issue without notification. CCA has confirmed this is now working.
Posted Jan 26, 2024 - 15:08 EST

Identified

Due to changes with MS Office 365, some caretakers are experiencing difficulties logging into webmail.

Impact
Edio web:
Some users are being prompted to enter their email addresses, which is not normal behavior.

Mobile app
1 For iOS users, the app displays a spinning wheel. We are actively working to resolve this issue as caretakers using IOS devices are currently unable to log into webmail using the mobile app.
2 Most Android users are able to log in normally.

Temporary workaround:
If prompted during the redirection process please enter your edio webmail address. This is formatted as such: ediousername@ccastudents.me where the “ediousername” portion is your username for edio.
Posted Nov 13, 2023 - 17:53 EST
This incident affected: MyEdio.