iReady technical difficulties
Incident Report for CCA Status Page
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 09:10 EDT
Investigating
#CCAStudents and #CCAFamilies: The company that provides students with access to complete the i-Ready benchmarks is experiencing technical issues and students are not able to access the i-Ready benchmarks. We are working with the company to resolve this issue and will provide an update as soon as possible. We apologize for any inconvenience. Thank you for your understanding.
Posted Sep 20, 2022 - 08:52 EDT