Powerschool Front End not Repsonding
Incident Report for CCA Status Page
Resolved
We have made some configuration changes to more even distribute load across the powerschool webservers, which has resolved the issue.
Posted May 16, 2022 - 11:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2022 - 08:50 EDT
Update
We are continuing to investigate this issue.
Posted May 16, 2022 - 08:08 EDT
Investigating
We are currently investigating this issue.
Posted May 16, 2022 - 08:07 EDT
This incident affected: Powerschool.